Mplayer не проигрывает mp4 [Решено]

Странная история с mplayer, до недавнего времени прекрасно работал,
после сборки некоторых программ, в частности, видеоредакторов avidemux, cinelerra,
mplayer перестал проигрывать видео mp4, работает ровно секунду и зависает, картинку видно.
Уже переставлял ffmpeg и mplayer. При открытии файла пытается использовать libavacodec.
Интересно, что vlc вообще не показывает картинку, только звук.
Проверял на нескольких файлах fullhd

Update:
Совсем странно, снес avidemux и cinelerra заодно vlc, mplayer и ffmpeg,
собрал три последние заново, без дополнительных фалгов, т.е. просто
emerge ffmpeg и mplayer снова стал проигывать mp4 и vlc нет...

Вот теперь знаю, где нужен флаг 3dnow
мой тюнер просит v4l и 3dnow
Во всяком случае, если собирать mplayer без этих флагов, то mencoder пишет
mmx2 supported but disabled
3dnow supported but disabled

P.S. Честно скажу, не знаю почему не работал и так не заработал vlc и почему все-таки заработал mplayer

Аналогичная проблема была,

Аналогичная проблема была, тоже перешёл на VLC.
В логах было что-то про ffmpeg, у меня началось после обновления ffmpeg и добавления к chromium флага system-ffmpeg (хотя хромиум не при чём, надо думать).
Странно, сейчас попробовал - работает.

Еще раз однократно случилось

Еще раз однократно случилось такое заедание с проигрыванием mp4 после захвата с тв-тюнера.
После перезагрузки все вернулось.

Ставил какой-то очередной

Ставил какой-то очередной пакет, не имеющий отношения к видео и получил после установки такое
existing preserved libs:

* used by /usr/lib64/ADM_plugins6/videoFilters/libADM_vf_CropCli.so (media-libs/avidemux-plugins-2.6.4-r1)
* used by /usr/lib64/ADM_plugins6/videoFilters/libADM_vf_HueCli.so (media-libs/avidemux-plugins-2.6.4-r1)
* used by /usr/lib64/ADM_plugins6/videoFilters/libADM_vf_chromaShiftCli.so (media-libs/avidemux-plugins-2.6.4-r1)
* used by 3 other files
* - /usr/lib64/libADM_UIQT46.so
* used by /usr/lib64/ADM_plugins6/videoEncoders/libADM_ve_x264_qt4.so (media-libs/avidemux-plugins-2.6.4-r1)
* used by /usr/lib64/ADM_plugins6/videoFilters/libADM_vf_HueQt4.so (media-libs/avidemux-plugins-2.6.4-r1)
* used by /usr/lib64/ADM_plugins6/videoFilters/libADM_vf_asharpQt4.so (media-libs/avidemux-plugins-2.6.4-r1)
Use emerge @preserved-rebuild to rebuild packages using these libraries
Я правильно понимаю, что они использовались только avidemux?
Т.е. сейчас как бы лежат зазря?

Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".