[РЕШЕНО]sys-fs/udev is blocking sys-apps/systemd

Добрый вечер.
Столкнулся с не понятной зависимостью.
Удаляю sys-fs/udev, но при следующем запуске команды обновления мира, опять таже песня, как быть в этом случае?

serv0 ~ # emerge -auvDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] sys-libs/libseccomp-2.1.1 USE="-static-libs" 111 kB
[ebuild U ] sys-libs/libcap-2.22-r2 [2.22] USE="pam" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild N ] dev-python/lxml-3.3.5 USE="threads -beautifulsoup3 -doc -examples" PYTHON_TARGETS="python2_7 python3_3 -python3_2 (-python3_4)" 3,387 kB
[ebuild N ] sys-apps/systemd-212-r5:0/2 USE="acl filecaps firmware-loader kmod pam policykit python seccomp -audit -cryptsetup -doc -gcrypt -gudev -http -introspection (-kdbus) -lzma -qrcode (-selinux) (-ssl) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild N ] sys-apps/gentoo-systemd-integration-4 52 kB
[ebuild U ] sys-power/upower-0.9.23-r3 [0.9.23-r2] USE="introspection -doc -ios (-systemd%)" 0 kB
[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-212-r5, sys-apps/gentoo-systemd-integration-4)
[blocks B ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-212-r1)
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-212-r1)

Total: 6 packages (2 upgrades, 4 new), Size of downloads: 3,548 kB
Conflict: 3 blocks (3 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-fs/udev-212-r1::gentoo, installed) pulled in by
>=sys-fs/udev-208:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,static-libs?] (>=sys-fs/udev-208:0/0[abi_x86_64(-)]) required by (virtual/libudev-208::gentoo, installed)
sys-fs/udev required by @selected
>=sys-fs/udev-208 required by (virtual/udev-208-r2::gentoo, installed)
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev,introspection?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev]) required by (virtual/libgudev-208::gentoo, installed)

(sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge) pulled in by
>=sys-apps/systemd-200 required by (sys-power/upower-0.9.23-r3::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Вам чёрным по белому или

Вам чёрным по белому или белым по чёрному написано:

[ebuild U ] sys-power/upower-0.9.23-r3 [0.9.23-r2] USE="introspection -doc -ios (-systemd%)" 0 kB
...
>=sys-apps/systemd-200 required by (sys-power/upower-0.9.23-r3::gentoo, ebuild scheduled for merge)

Первое выделенное указывает на то, что у upower удалили флаг systemd как раз в версии 0.9.23-r3

В версии r2 было так:

RDEPEND="${COMMON_DEPEND}
	kernel_linux? (
		!systemd? ( >=sys-power/pm-utils-1.4.1 )
		systemd? (
			app-shells/bash
			>=sys-apps/systemd-200
			)
		)"

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-power/upower/upower-0.9.23-r2.ebuild

В текущей версии (r3) вот так:

RDEPEND="${COMMON_DEPEND}
	kernel_linux? (
		app-shells/bash
		>=sys-apps/systemd-200
	)"

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-power/upower/upower-0.9.23-r3.ebuild

Причина этого указана в changelog`е: http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-power/upower/ChangeLog

*upower-0.9.23-r3 (02 Jun 2014)

  02 Jun 2014; Samuli Suominen <ssuominen@gentoo.org> +upower-0.9.23-r3.ebuild:
  Leave 0.9.23-r3 with --disable-deprecated for sys-apps/systemd users.
  Users who want UPower with sys-power/pm-utils support will want to emerge
  >=sys-power/upower-pm-utils-0.9.23 instead.

...

  26 May 2014; Samuli Suominen <ssuominen@gentoo.org> upower-0.99.0.ebuild:
  This release is mainly for use with sys-apps/systemd because upstream removed
  support for sys-power/pm-utils completely from git master. The 0.9 branch is
  for sys-power/pm-utils use. Adjust ebuild accordingly.

Спасибо за подсказзку. Удалил

Спасибо за подсказзку.
Удалил sys-power/upower
Поставил sys-power/upower-pm-utils

Что бы ты не делал , жизнь слишком коротка!
Блог о BSD системах.

Что это значит: [SOLVED],

У меня аналогичная проблема,

У меня аналогичная проблема, но я уже снес upower, но
emerge -pv sys-power/upower-pm-utils на выходе дает


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] virtual/libiconv-0-r1 [0] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild U ] dev-libs/libffi-3.0.13-r1 [3.0.11] USE="-debug -pax_kernel% -static-libs {-test}" ABI_X86="(64%*) (-32) (-x32)" 826 kB
[ebuild N ] sys-libs/libseccomp-2.1.1 USE="-static-libs" 111 kB
[ebuild U ] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild U ] sys-libs/zlib-1.2.8-r1 [1.2.8] USE="minizip static-libs" ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild U ] sys-apps/kmod-17 [12-r1] USE="tools zlib -debug -doc -lzma -python% -static-libs" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% (-python3_4)" 0 kB
[ebuild U ] sys-devel/binutils-2.23.2 [2.22-r1] USE="cxx nls zlib -multislot -multitarget -static-libs {-test} -vanilla" 0 kB
[ebuild U ] dev-util/gtk-doc-am-1.20 [1.18] 629 kB
[uninstall ] dev-util/gtk-doc-1.18-r1 USE="debug doc -emacs -highlight {-test} -vim"
[blocks b ] [ebuild U ~] dev-libs/glib-2.40.0-r1:2 [2.34.3:2] USE="debug mime%* (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64%*) -32% (-x32)" PYTHON_TARGETS="python2_7%* (-python2_6)" 6,852 kB
[ebuild N ] sys-apps/systemd-212-r5:0/2 USE="acl filecaps firmware-loader gudev kmod pam seccomp -audit -cryptsetup -doc -gcrypt -http -introspection (-kdbus) -lzma -policykit -python -qrcode (-selinux) (-ssl) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 0 kB
[ebuild N ] sys-apps/gentoo-systemd-integration-4 52 kB
[ebuild N ] virtual/libgudev-208 USE="-introspection -static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild N ] virtual/libudev-208:0/1 USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 0 kB
[ebuild U ] virtual/udev-208-r2 [197-r3] USE="gudev -introspection -static-libs (-hwdb%*) (-keymap%*) (-kmod%*) (-selinux%)" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild U ] sys-apps/hwids-20140317 [20130329] USE="udev" 0 kB
[ebuild N ] sys-power/upower-pm-utils-0.9.23-r2 USE="introspection -ios" 416 kB
[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/gentoo-systemd-integration-4, sys-apps/systemd-212-r5)
[blocks B ] [blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-200)

Total: 16 packages (10 upgrades, 6 new, 1 uninstall), Size of downloads: 8,885 kB
Conflict: 4 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

(dev-libs/glib-2.40.0-r1::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/glib-2.34.3:2=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge)

(dev-libs/glib-2.34.3::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

sys-libs/zlib:0

(sys-libs/zlib-1.2.8::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
>=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/glib-2.40.0-r1::gentoo, ebuild scheduled for merge)

virtual/udev:0

(virtual/udev-197-r3::gentoo, installed) pulled in by
>=virtual/udev-197[gudev,hwdb] required by (sys-fs/udisks-1.0.4-r5::gentoo, installed)
>=virtual/udev-197[gudev,hwdb] required by (sys-fs/udisks-2.1.0::gentoo, installed)
=virtual/udev-197-r3 required by (virtual/dev-manager-0::gentoo, installed)
(and 19 more with the same problems)

(virtual/udev-208-r2::gentoo, ebuild scheduled for merge) pulled in by
>=virtual/udev-206 required by (sys-apps/hwids-20140317::gentoo, ebuild scheduled for merge)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-apps/kmod-17::gentoo, ebuild scheduled for merge) pulled in by
sys-apps/kmod[tools] required by (virtual/modutils-0::gentoo, installed)
>=sys-apps/kmod-15:0= required by (sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge)
>=sys-apps/kmod-12 required by (sys-fs/udev-200::gentoo, installed)

(sys-apps/openrc-0.11.8::gentoo, installed) pulled in by
sys-apps/openrc required by (sys-fs/udev-init-scripts-25::gentoo, installed)
sys-apps/openrc required by @system
sys-apps/openrc required by (dev-db/mysql-init-scripts-2.0_pre1-r3::gentoo, installed)

(sys-fs/udev-200::gentoo, installed) pulled in by
>=sys-fs/udev-197-r8[gudev,hwdb,keymap,kmod] required by (virtual/udev-197-r3::gentoo, installed)
sys-fs/udev required by @selected
sys-fs/udev required by (app-misc/media-player-info-17::gentoo, installed)

(sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge) pulled in by
>=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_64(-),gudev]) required by (virtual/libgudev-208::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_64(-)]) required by (virtual/libudev-208::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-208:0 required by (virtual/udev-208-r2::gentoo, ebuild scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

!!! The following installed packages are masked:
- dev-java/sun-jdk-1.6.0.45::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman (30 Jun 2013)
# Sun JDK and JRE contain critical vulnerabilities and receive no further
# updates; masking to make users aware of this, users that still need this
# package and have no alternative can unmask at their own risk. See bug #473830.
#
# This is continued by Oracle Corporation, which has acquired Sun Microsystems
# in early 2010; as per http://en.wikipedia.org/wiki/Sun_acquisition_by_Oracle
#
# Users are suggested to upgrade to one of the newer Oracle packages like
# dev-java/oracle-jdk-bin or dev-java/oracle-jre-bin or choose another
# alternative we provide; eg. the IBM JDK/JRE or the open source IcedTea.
#
# Most of these packages provide a jce USE flag for those whom need the
# Java Cryptographic Extension Unlimited Strength Policy USE flag; whether that
# works depends from VM to VM, it seems to work for most except for the IBM VMs.

- net-nds/openldap-2.4.30::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov
(20 Mar 2014)
# Security mask of vulnerable versions, wrt bug #424167

- media-video/vlc-2.0.5::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman (8 Jun 2014)
# Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
#
# A vulnerability has been discovered in VLC Media Player, which can be
# exploited by malicious people to compromise a user's system.
#
# Some ebuilds also have other buffer and integer overflow security bugs like
# CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
#
# Users should consider to upgrade VLC Media Player to at least version 2.1.2.

- virtual/perl-Module-CoreList-2.800.0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Huettel (29 Jun 2014)
# Mask perl-5.12 and related package versions prior to removal
# If you require the Switch package, emerge perl-core/Switch

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


т.е. udev блокирует systemd, но пытается тащить за собой. Как с этим бороться ?

С наилучшими пожеланиями,
Юрий Русинов.

YuriyRusinov

YuriyRusinov написал(а):
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-200)

(sys-fs/udev-200::gentoo, installed) pulled in by
>=sys-fs/udev-197-r8[gudev,hwdb,keymap,kmod] required by (virtual/udev-197-r3::gentoo, installed)
sys-fs/udev required by @selected
sys-fs/udev required by (app-misc/media-player-info-17::gentoo, installed)

(sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge) pulled in by

Потому что установленный sys-fs/udev-200 блокирует установку неустановленного sys-apps/systemd.

вначале нужно обновить udev до новой версии emerge -pv udev с предварительной проверкой на возможные блоки по пути решая остальные зависимости

и только потом emerge -pv sys-power/upower-pm-utils.

И потом, для решения Вашей проблемы, создайте свою тему! Эта уже как [SOLVED][РЕШЕНО] "идёт" (см. тему).

Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".