[SOLVED] После обновления мира в новом ядре нет драйвера ath9k. Help me, please.

Здравствуйте, дорогие форумчане.
Обновлял мир (делал это в первый раз), видел, как загружались исходники ядра новой версии.
У меня было ядро 4.14.65-gentoo, стало - 4.19.23-gentoo.
В старом ядре был драйвер ath9k, в новом его не нахожу (нет, наверное).

Вопрос: Что делать?
Я новичок в Gentoo, помогите, пожалуйста.

Загрузись с любого свежего

Загрузись с любого свежего LiveCD/DVD с тем же ядром (например, новый SRCD v6 использует ядро v4.19) и посмотри какой драйвер поддерживает твой чип:

lspci -k

Спасибо, решено.

Спасибо.
Я использую menuconfig.
Есть там два пункта: Network devices и Device drivers.
Оказалось, в Network devices были отключены некоторые опции, из-за которых в Device drivers не появлялся нужный мне пункт. Его просто не было из-за этого, а я думал, что его выпилили в связи с новым ядром.

?

Спасибо.

Спасибо.
Правила форума не читал, каюсь.
Искал, как сделать, чтобы появилось [SOLVED].
Почему-то совсем не догадался, что надо просто отредактировать сообщение.
Судорожно побежал пилить Gentoo. :)

/

Глупый вопрос: как ядро собирал?
make oldconfig?

Ну и при сохранении возможности загрузки старого — я бы не назвал проблему критичной.

:wq
--
Live free or die

Да, именно make oldconfig.

Спасибо, я уже разобрался. Проблема не критична, но я люблю секс с Генту. Мне надо именно новое ядро.

Вдогонку...

Насчёт нового ядра, ath9k и секса. У самого на ноуте грешная железяка Qualcomm Atheros ar9485, заметил, что последнее время по вайфаю связь с чудовищными затыками. Облазил весь гугл, бесполезно. В итоге на ЛОРе наткнулся на идею "а не откатить ли ядро, типа с 4.14 пошли глюки в ath9k", собрал 4.9.последнее - и всё летает.
Так что имейте в виду, что в новых ядрах иногда портятся старые дрова, и извращённый секс вам обеспечен ;-)

/

Danhuu написал(а):
Насчёт нового ядра, ath9k и секса. У самого на ноуте грешная железяка Qualcomm Atheros ar9485, заметил, что последнее время по вайфаю связь с чудовищными затыками. Облазил весь гугл, бесполезно. В итоге на ЛОРе наткнулся на идею "а не откатить ли ядро, типа с 4.14 пошли глюки в ath9k", собрал 4.9.последнее - и всё летает.
Так что имейте в виду, что в новых ядрах иногда портятся старые дрова, и извращённый секс вам обеспечен ;-)

Не только дрова.
У меня при попытке обновления на… НЯП тогда ещё 4.12 пробовали стабилизировать, запросы overlayfs выросли до несоместимых с наличными ресурсами.

:wq
--
Live free or die

!!!

Ты не прав.
Проблему можно считать решённой только после регистрации на bgo!

:wq
--
Live free or die

Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".