[SOLVED] Блокировка

Подскажите, пожалуйста, сам пока не могу разобраться (мало опыта):

$ sudo emerge -pvuDN --with-bdeps=y world
Пароль:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] dev-libs/libnl-3.2.27:3::gentoo [3.2.26:3::gentoo] USE="-python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3" 885 KiB
[ebuild U ] dev-db/sqlite-3.9.2:3::gentoo [3.8.10.2:3::gentoo] USE="readline -debug -doc -icu -secure-delete -static-libs -tcl {-test} -tools" ABI_X86="(64) -32 (-x32)" 2 231 KiB
[ebuild N ] dev-libs/libgudev-230::gentoo USE="introspection -debug -static-libs" ABI_X86="(64) -32 (-x32)" 252 KiB
[ebuild U ] sys-apps/hwids-20150717-r1::gentoo [20150129::gentoo] USE="net pci udev usb" 1 705 KiB
[ebuild U ] app-text/docbook-xsl-stylesheets-1.79.0::gentoo [1.78.0-r1::gentoo] USE="-ruby" 21 459 KiB
[ebuild N ] virtual/libgudev-230::gentoo USE="introspection -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild N ] sys-fs/udisks-2.1.4:2::gentoo USE="gptfdisk introspection -cryptsetup -debug (-selinux) -systemd" 0 KiB
[blocks B ] sys-fs/udev[gudev(-)] ("sys-fs/udev[gudev(-)]" is blocking dev-libs/libgudev-230)
[blocks B ] dev-libs/libgudev ("dev-libs/libgudev" is blocking sys-fs/udev-216)

Total: 7 packages (4 upgrades, 3 new), Size of downloads: 26 530 KiB
Conflict: 2 blocks (2 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-fs/udev-216:0/0::gentoo, installed) pulled in by
sys-fs/udev required by @selected
>=sys-fs/udev-208-r1 required by (virtual/udev-215:0/0::gentoo, installed)
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-)]) required by (virtual/libudev-215-r1:0/1::gentoo, installed)

(dev-libs/libgudev-230:0/0::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/libgudev:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,introspection?,static-libs?] (dev-libs/libgudev:0/0[abi_x86_64(-),introspection]) required by (virtual/libgudev-230:0/0::gentoo, ebuild scheduled for merge)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
Поменять флаг udev : gudev на -gudev?
Заранее спасибо

Для начала emerge -1 --nodeps

Для начала

emerge -1 --nodeps $(qlist -IC udev) -pv

Эх я, торопыга, уже флаг

Эх я, торопыга, уже флаг сменил. Обновил.

$ sudo emerge -1 --nodeps $(qlist -IC udev) -pv
Пароль:

These are the packages that would be merged, in order:

[ebuild R ] dev-libs/libgudev-230::gentoo USE="introspection -debug -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild R ] sys-fs/udev-216::gentoo USE="acl firmware-loader introspection kmod -doc -gudev (-selinux) -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild R ] sys-fs/udev-init-scripts-27::gentoo 0 KiB
[ebuild R ] virtual/libgudev-230::gentoo USE="introspection -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild R ] virtual/libudev-215-r1:0/1::gentoo USE="-static-libs -systemd" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild R ] virtual/udev-215::gentoo USE="-systemd" 0 KiB

Total: 6 packages (6 reinstalls), Size of downloads: 0 KiB

гента прощай

Спасибо за подсказку, буду

Спасибо за подсказку, буду знать впредь.

гента прощай

* Messages for package

* Messages for package sys-fs/udev-216:

*
* Starting from version >= 197 the new predictable network interface names are
* used by default, see:
* http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
* http://cgit.freedesktop.org/systemd/systemd/tree/src/udev/udev-builtin-net_id.c
*
* Example command to get the information for the new interface name before booting
* (replace with, for example, eth0):
* # udevadm test-builtin net_id /sys/class/net/ 2> /dev/null
*
* You can use either kernel parameter "net.ifnames=0", create empty
* file /etc/systemd/network/99-default.link, or symlink it to /dev/null
* to disable the feature.
*
* You need to restart udev as soon as possible to make the upgrade go
* into effect.
* The method you use to do this depends on your init system.
* For sys-apps/openrc users it is:
* # /etc/init.d/udev --nodeps restart
*
* For more information on udev on Gentoo, upgrading, writing udev rules, and
* fixing known issues visit:
* https://wiki.gentoo.org/wiki/Udev
* https://wiki.gentoo.org/wiki/Udev/upgrade

Вот это выдало - это серьезно?

По-моему уже давно в прошлом такие новости, нет?

гента прощай

Тебе ссылки дали - читай! :)

Тебе ссылки дали - читай! :)

ушел)

ушел)...

Узнал самое главное наверно из всего этого - udev должен быть в глобальных флагах.
На сегодня и это неплохо)

гента прощай

Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".